diff --git a/.github/workflows/main_doc.yml b/.github/workflows/main-doc.yml
similarity index 93%
rename from .github/workflows/main_doc.yml
rename to .github/workflows/main-doc.yml
index 04016d1..bb4eab7 100644
--- a/.github/workflows/main_doc.yml
+++ b/.github/workflows/main-doc.yml
@@ -1,6 +1,6 @@
---
# This is deploying the latest commits on main to main documentation
-name: Mkdocs
+name: Mkdocs Deploy for main
on:
push:
branches:
@@ -34,4 +34,4 @@ jobs:
- name: 'Build mkdocs content and deploy to gh-pages to main'
run: |
pip install .[doc]
- mike deploy --push main
+ mike deploy --push main
\ No newline at end of file
diff --git a/.github/workflows/release.yml b/.github/workflows/release.yml
index d85df38..e4e3676 100644
--- a/.github/workflows/release.yml
+++ b/.github/workflows/release.yml
@@ -3,10 +3,10 @@ name: "Tag & Release management"
on:
push:
tags:
- - 'v[0-9]+.[0-9]+.[0-9]+$' # Push events to matching v*, i.e. v1.0, v20.15.10
+ - 'v*.*.*'
jobs:
pypi:
- name: Publish version to Pypi servers
+ name: Publish Python 🐍 distribution 📦 to PyPI
runs-on: ubuntu-latest
environment:
name: pypi
@@ -26,7 +26,7 @@ jobs:
run: |
python -m build
- - name: Publish package to Pypi server
+ - name: Publish distribution 📦 to PyPI
uses: pypa/gh-action-pypi-publish@release/v1
with:
user: __token__
@@ -118,7 +118,7 @@ jobs:
release-doc:
name: "Publish documentation for release ${{github.ref_name}}"
runs-on: ubuntu-latest
- needs: [docker-in-docker]
+ needs: [docker_in_docker]
steps:
- uses: actions/checkout@v4
with:
diff --git a/README.md b/README.md
index c5935fa..2c1aa5d 100644
--- a/README.md
+++ b/README.md
@@ -12,6 +12,8 @@
A project to download Arista softwares to local folder, Cloudvision or EVE-NG. It comes in 2 way: a framework with object to automate Arista software download and a CLI for human activities.
+
+
> [!CAUTION]
> This script should not be deployed on EOS device. If you do that, there is no support to expect from Arista TAC team.
diff --git a/docs/README.md b/docs/README.md
index dc1d2e3..c0e5e9f 100644
--- a/docs/README.md
+++ b/docs/README.md
@@ -10,12 +10,41 @@
A project to download Arista softwares to local folder, Cloudvision or EVE-NG. It comes in 2 way: a framework with object to automate Arista software download and a CLI for human activities.
-
+
> [!CAUTION]
> This script should not be deployed on EOS device. If you do that, there is no support to expect from Arista TAC team.
+## Key Features
+
+- **Download** EOS images locally with various options based on image type.
+- **Import** your `cEOS` container into your local Docker registry.
+- Import specific versions into **Docker or EVE-NG**.
+
+## Example Commands
+
```bash
+# Install eos-downloader from PyPI
+pip install eos-downloader
+
+# Download EOS software for EOS 64-bit
+ardl --token get eos --format 64 --latest --release-type M
+
+# Get the latest version of EOS using Docker format
+ardl get eos --latest --format cEOS
+
+# Get the latest maintenance type version in branch 4.29
+ardl get eos --branch 4.29 --format cEOS --release-type M
+
+# Get a specific version
+ardl get eos --version 4.29.4M
+
+# Get a specific version and import to Docker
+ardl get eos --version 4.29.4M --import-docker
+
+# Get a specific version and import to EVE-NG
+ardl get eos --version 4.33.0F --eve-ng
+
# install eos-downloader from pypi
pip install eos-downloader
diff --git a/docs/imgs/logo.jpg b/docs/imgs/logo.jpg
new file mode 100644
index 0000000..a3845ad
Binary files /dev/null and b/docs/imgs/logo.jpg differ
diff --git a/pyproject.toml b/pyproject.toml
index c71fb1b..6e85eca 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,7 +6,7 @@ build-backend = "setuptools.build_meta"
[project]
name = "eos_downloader"
-version = "v0.12.0"
+version = "v0.12.1"
readme = "README.md"
authors = [{ name = "Thomas Grimonet", email = "thomas.grimonet@gmail.com" }]
maintainers = [
@@ -103,7 +103,7 @@ doc = [
]
[project.urls]
-Homepage = "https://www.github.com/titom73/eos-downloader"
+Homepage = "https://titom73.github.io/eos-downloader/"
"Bug Tracker" = "https://www.github.com/titom73/eos-downloader/issues"
Contributing = "https://www.github.com/titom73/eos-downloader"
@@ -123,7 +123,7 @@ namespaces = false
# Version
################################
[tool.bumpver]
-current_version = "0.12.0"
+current_version = "0.12.1"
version_pattern = "MAJOR.MINOR.PATCH[TAGNUM]"
commit_message = "bump: Version {old_version} -> {new_version}"
commit = true