17 lines
233 B
Protocol Buffer
17 lines
233 B
Protocol Buffer
syntax = "proto3";
|
|
|
|
package oneof_empty;
|
|
|
|
message Nothing {}
|
|
|
|
message MaybeNothing {
|
|
string sometimes = 42;
|
|
}
|
|
|
|
message Test {
|
|
oneof empty {
|
|
Nothing nothing = 1;
|
|
MaybeNothing maybe1 = 2;
|
|
MaybeNothing maybe2 = 3;
|
|
}
|
|
}
|