Disabling fzf until pyfzf has passed NEW (Closes: #1087961).
Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
parent
da29ead990
commit
3a6268ac5b
2 changed files with 66 additions and 0 deletions
65
debian/patches/debian/0001-disable-fzf.patch
vendored
Normal file
65
debian/patches/debian/0001-disable-fzf.patch
vendored
Normal file
|
@ -0,0 +1,65 @@
|
|||
Author: Daniel Baumann <daniel.baumann@progress-linux.org>
|
||||
Description: Disabling fzf until pyfzf has passed NEW (Closes: #1087961).
|
||||
|
||||
diff -Naurp mycli.orig/mycli/packages/toolkit/fzf.py mycli/mycli/packages/toolkit/fzf.py
|
||||
--- mycli.orig/mycli/packages/toolkit/fzf.py
|
||||
+++ mycli/mycli/packages/toolkit/fzf.py
|
||||
@@ -1,45 +1,14 @@
|
||||
from shutil import which
|
||||
|
||||
-from pyfzf import FzfPrompt
|
||||
from prompt_toolkit import search
|
||||
from prompt_toolkit.key_binding.key_processor import KeyPressEvent
|
||||
|
||||
from .history import FileHistoryWithTimestamp
|
||||
|
||||
|
||||
-class Fzf(FzfPrompt):
|
||||
- def __init__(self):
|
||||
- self.executable = which("fzf")
|
||||
- if self.executable:
|
||||
- super().__init__()
|
||||
-
|
||||
- def is_available(self) -> bool:
|
||||
- return self.executable is not None
|
||||
-
|
||||
-
|
||||
def search_history(event: KeyPressEvent):
|
||||
buffer = event.current_buffer
|
||||
history = buffer.history
|
||||
|
||||
- fzf = Fzf()
|
||||
-
|
||||
- if fzf.is_available() and isinstance(history, FileHistoryWithTimestamp):
|
||||
- history_items_with_timestamp = history.load_history_with_timestamp()
|
||||
-
|
||||
- formatted_history_items = []
|
||||
- original_history_items = []
|
||||
- for item, timestamp in history_items_with_timestamp:
|
||||
- formatted_item = item.replace('\n', ' ')
|
||||
- timestamp = timestamp.split(".")[0] if "." in timestamp else timestamp
|
||||
- formatted_history_items.append(f"{timestamp} {formatted_item}")
|
||||
- original_history_items.append(item)
|
||||
-
|
||||
- result = fzf.prompt(formatted_history_items, fzf_options="--tiebreak=index")
|
||||
-
|
||||
- if result:
|
||||
- selected_index = formatted_history_items.index(result[0])
|
||||
- buffer.text = original_history_items[selected_index]
|
||||
- buffer.cursor_position = len(buffer.text)
|
||||
- else:
|
||||
- # Fallback to default reverse incremental search
|
||||
- search.start_search(direction=search.SearchDirection.BACKWARD)
|
||||
+ # Fallback to default reverse incremental search
|
||||
+ search.start_search(direction=search.SearchDirection.BACKWARD)
|
||||
diff -Naurp mycli.orig/setup.py mycli/setup.py
|
||||
--- mycli.orig/setup.py 2024-11-15 07:48:27.438686616 +0100
|
||||
+++ mycli/setup.py 2024-11-21 07:25:19.265039508 +0100
|
||||
@@ -30,7 +30,6 @@ install_requirements = [
|
||||
'cli_helpers[styles] >= 2.2.1',
|
||||
'pyperclip >= 1.8.1',
|
||||
'pyaes >= 1.6.1',
|
||||
- 'pyfzf >= 0.3.1',
|
||||
]
|
||||
|
||||
if sys.version_info.minor < 9:
|
1
debian/patches/series
vendored
Normal file
1
debian/patches/series
vendored
Normal file
|
@ -0,0 +1 @@
|
|||
debian/0001-disable-fzf.patch
|
Loading…
Add table
Reference in a new issue