Removing disabling of fzf now that pyfzf is available in sid.
Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
parent
c26c594373
commit
3a7abd0df5
3 changed files with 1 additions and 66 deletions
1
debian/control
vendored
1
debian/control
vendored
|
@ -23,6 +23,7 @@ Depends:
|
|||
python3-cli-helpers,
|
||||
python3-prompt-toolkit (>= 2.0),
|
||||
python3-sqlglot,
|
||||
python3-pyfzf,
|
||||
python3-sqlparse (>= 0.4),
|
||||
python3-tabulate,
|
||||
python3-terminaltables,
|
||||
|
|
65
debian/patches/debian/0001-disable-fzf.patch
vendored
65
debian/patches/debian/0001-disable-fzf.patch
vendored
|
@ -1,65 +0,0 @@
|
|||
Author: Daniel Baumann <daniel.baumann@progress-linux.org>
|
||||
Description: Disabling fzf until pyfzf has passed NEW (Closes: #1087961).
|
||||
|
||||
diff -Naurp mycli.orig/mycli/packages/toolkit/fzf.py mycli/mycli/packages/toolkit/fzf.py
|
||||
--- mycli.orig/mycli/packages/toolkit/fzf.py
|
||||
+++ mycli/mycli/packages/toolkit/fzf.py
|
||||
@@ -1,45 +1,14 @@
|
||||
from shutil import which
|
||||
|
||||
-from pyfzf import FzfPrompt
|
||||
from prompt_toolkit import search
|
||||
from prompt_toolkit.key_binding.key_processor import KeyPressEvent
|
||||
|
||||
from .history import FileHistoryWithTimestamp
|
||||
|
||||
|
||||
-class Fzf(FzfPrompt):
|
||||
- def __init__(self):
|
||||
- self.executable = which("fzf")
|
||||
- if self.executable:
|
||||
- super().__init__()
|
||||
-
|
||||
- def is_available(self) -> bool:
|
||||
- return self.executable is not None
|
||||
-
|
||||
-
|
||||
def search_history(event: KeyPressEvent):
|
||||
buffer = event.current_buffer
|
||||
history = buffer.history
|
||||
|
||||
- fzf = Fzf()
|
||||
-
|
||||
- if fzf.is_available() and isinstance(history, FileHistoryWithTimestamp):
|
||||
- history_items_with_timestamp = history.load_history_with_timestamp()
|
||||
-
|
||||
- formatted_history_items = []
|
||||
- original_history_items = []
|
||||
- for item, timestamp in history_items_with_timestamp:
|
||||
- formatted_item = item.replace("\n", " ")
|
||||
- timestamp = timestamp.split(".")[0] if "." in timestamp else timestamp
|
||||
- formatted_history_items.append(f"{timestamp} {formatted_item}")
|
||||
- original_history_items.append(item)
|
||||
-
|
||||
- result = fzf.prompt(formatted_history_items, fzf_options="--tiebreak=index")
|
||||
-
|
||||
- if result:
|
||||
- selected_index = formatted_history_items.index(result[0])
|
||||
- buffer.text = original_history_items[selected_index]
|
||||
- buffer.cursor_position = len(buffer.text)
|
||||
- else:
|
||||
- # Fallback to default reverse incremental search
|
||||
- search.start_search(direction=search.SearchDirection.BACKWARD)
|
||||
+ # Fallback to default reverse incremental search
|
||||
+ search.start_search(direction=search.SearchDirection.BACKWARD)
|
||||
diff -Naurp mycli.orig/pyproject.toml mycli/pyproject.toml
|
||||
--- mycli.orig/pyproject.toml
|
||||
+++ mycli/pyproject.toml
|
||||
@@ -20,7 +20,6 @@ dependencies = [
|
||||
"cli_helpers[styles] >= 2.2.1",
|
||||
"pyperclip >= 1.8.1",
|
||||
"pyaes >= 1.6.1",
|
||||
- "pyfzf >= 0.3.1",
|
||||
"importlib_resources >= 5.0.0; python_version<'3.9'",
|
||||
]
|
||||
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
|
@ -1 +0,0 @@
|
|||
debian/0001-disable-fzf.patch
|
Loading…
Add table
Reference in a new issue