1
0
Fork 0
pgcli/tests/features/fixture_data/help_commands.txt
Daniel Baumann ec5391b244
Adding upstream version 3.1.0.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-09 19:48:22 +01:00

64 lines
1.2 KiB
Text

Command
Description
\#
Refresh auto-completions.
\?
Show Commands.
\T [format]
Change the table format used to output results
\c[onnect] database_name
Change to a new database.
\copy [tablename] to/from [filename]
Copy data between a file and a table.
\d[+] [pattern]
List or describe tables, views and sequences.
\dT[S+] [pattern]
List data types
\db[+] [pattern]
List tablespaces.
\df[+] [pattern]
List functions.
\di[+] [pattern]
List indexes.
\dm[+] [pattern]
List materialized views.
\dn[+] [pattern]
List schemas.
\ds[+] [pattern]
List sequences.
\dt[+] [pattern]
List tables.
\du[+] [pattern]
List roles.
\dv[+] [pattern]
List views.
\dx[+] [pattern]
List extensions.
\e [file]
Edit the query with external editor.
\h
Show SQL syntax and help.
\i filename
Execute commands from file.
\l
List databases.
\n[+] [name] [param1 param2 ...]
List or execute named queries.
\nd [name]
Delete a named query.
\ns name query
Save a named query.
\o [filename]
Send all query results to file.
\pager [command]
Set PAGER. Print the query results via PAGER.
\pset [key] [value]
A limited version of traditional \pset
\refresh
Refresh auto-completions.
\sf[+] FUNCNAME
Show a function's definition.
\timing
Toggle timing of commands.
\x
Toggle expanded output.