1
0
Fork 0
pgcli/tests/features/steps/specials.py
Daniel Baumann 39b7cc8559
Merging upstream version 3.2.0.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-09 19:58:08 +01:00

31 lines
724 B
Python

"""
Steps for behavioral style tests are defined in this module.
Each step is defined by the string decorating it.
This string is used to call the step in "*.feature" file.
"""
from behave import when, then
import wrappers
@when("we refresh completions")
def step_refresh_completions(context):
"""
Send refresh command.
"""
context.cli.sendline("\\refresh")
@then("we see completions refresh started")
def step_see_refresh_started(context):
"""
Wait to see refresh output.
"""
wrappers.expect_pager(
context,
[
"Auto-completion refresh started in the background.\r\n",
"Auto-completion refresh restarted.\r\n",
],
timeout=2,
)