1
0
Fork 0

Refreshing platformdirs.patc.

Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
Daniel Baumann 2025-04-16 08:54:52 +02:00
parent 78e8ed566c
commit 335f6cb574
Signed by: daniel
GPG key ID: FBB4F0E80A80222F

View file

@ -15,19 +15,31 @@ diff -Naurp ptpython.orig/README.rst ptpython/README.rst
precise location for your platform. A ``PTPYTHON_CONFIG_HOME`` environment
variable, if set, can also be used to explicitly override where configuration
is looked for.
diff -Naurp ptpython.orig/ptpython/entry_points/run_ptpython.py ptpython/ptpython/entry_points/run_ptpython.py
--- ptpython.orig/ptpython/entry_points/run_ptpython.py
+++ ptpython/ptpython/entry_points/run_ptpython.py
@@ -33,7 +33,7 @@ import sys
diff -Naurp ptpython.orig/pyproject.toml ptpython/pyproject.toml
--- ptpython.orig/pyproject.toml
+++ ptpython/pyproject.toml
@@ -18,7 +18,7 @@ classifiers = [
]
requires-python = ">=3.8"
dependencies = [
- "appdirs",
+ "platformdirs",
"jedi>=0.16.0",
# Use prompt_toolkit 3.0.43, because of `OneStyleAndTextTuple` import.
"prompt_toolkit>=3.0.43,<3.1.0",
diff -Naurp ptpython.orig/src/ptpython/entry_points/run_ptpython.py ptpython/src/ptpython/entry_points/run_ptpython.py
--- ptpython.orig/src/ptpython/entry_points/run_ptpython.py
+++ ptpython/src/ptpython/entry_points/run_ptpython.py
@@ -34,7 +34,7 @@ from importlib import metadata
from textwrap import dedent
from typing import IO
from typing import Protocol
-import appdirs
+import platformdirs
from prompt_toolkit.formatted_text import HTML
from prompt_toolkit.shortcuts import print_formatted_text
@@ -107,9 +107,9 @@ def get_config_and_history_file(namespac
@@ -106,9 +106,9 @@ def get_config_and_history_file(namespac
"""
config_dir = os.environ.get(
"PTPYTHON_CONFIG_HOME",
@ -39,15 +51,3 @@ diff -Naurp ptpython.orig/ptpython/entry_points/run_ptpython.py ptpython/ptpytho
# Create directories.
for d in (config_dir, data_dir):
diff -Naurp ptpython.orig/setup.py ptpython/setup.py
--- ptpython.orig/setup.py
+++ ptpython/setup.py
@@ -26,7 +26,7 @@ setup(
packages=find_packages("."),
package_data={"ptpython": ["py.typed"]},
install_requires=[
- "appdirs",
+ "platformdirs",
"importlib_metadata;python_version<'3.8'",
"jedi>=0.16.0",
# Use prompt_toolkit 3.0.43, because of `OneStyleAndTextTuple` import.