1
0
Fork 0
ptpython/tests/run_tests.py
Daniel Baumann 568aae77cf
Merging upstream version 3.0.23.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-09 18:30:14 +01:00

24 lines
581 B
Python
Executable file

#!/usr/bin/env python
from __future__ import annotations
import unittest
import ptpython.completer
import ptpython.eventloop
import ptpython.filters
import ptpython.history_browser
import ptpython.key_bindings
import ptpython.layout
import ptpython.python_input
import ptpython.repl
import ptpython.style
import ptpython.utils
import ptpython.validator
# For now there are no tests here.
# However this is sufficient for Travis to do at least a syntax check.
# That way we are at least sure to restrict to the Python 2.6 syntax.
if __name__ == "__main__":
unittest.main()