Fixing baseline violations on armel and i386, thanks to Adrian Bunk <bunk@debian.org> (Closes: #993010).

Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
Daniel Baumann 2025-02-09 07:41:17 +01:00
parent 45692b75c6
commit 4ce65563ea
Signed by: daniel
GPG key ID: FBB4F0E80A80222F
4 changed files with 49 additions and 3 deletions

View file

@ -0,0 +1,17 @@
Author: Adrian Bunk <bunk@debian.org>
Description: Fix USE_CC_BUILTINS.
diff -Naurp ck.orig/configure ck/configure
--- ck.orig/configure
+++ ck/configure
@@ -551,8 +551,8 @@ else
fi
if test "$USE_CC_BUILTINS"; then
- CFLAGS="$CFLAGS -DCK_CC_BUILTINS"
- PC_CFLAGS="-DCK_CC_BULITINS"
+ CFLAGS="$CFLAGS -DCK_USE_CC_BUILTINS=1"
+ PC_CFLAGS="-DCK_USE_CC_BUILTINS=1"
fi
# `which` on Solaris sucks

View file

@ -0,0 +1,23 @@
Author: Adrian Bunk <bunk@debian.org>
Description: Don't pass -msse -msse2 with --disable-sse on x86.
diff -Naurp ck.orig/build/ck.build.x86 ck/build/ck.build.x86
--- ck.orig/build/ck.build.x86
+++ ck/build/ck.build.x86
@@ -1,2 +1,2 @@
-CFLAGS+=-m32 -D__x86__ -msse -msse2
+CFLAGS+=-m32 -D__x86__
LDFLAGS+=-m32
diff -Naurp ck.orig/configure ck/configure
--- ck.orig/configure
+++ ck/configure
@@ -424,6 +424,9 @@ case $PLATFORM in
LDFLAGS="-m64 $LDFLAGS"
;;
i386|i486|i586|i686|i586_i686|pentium*|athlon*|k5|k6|k6_2|k6_3)
+ if test "${SSE_DISABLE}" = "CK_MD_SSE_ENABLE"; then
+ CFLAGS="$CFLAGS -msse -msse2"
+ fi
LSE_ENABLE="CK_MD_LSE_DISABLE"
MM="${MM:-"CK_MD_TSO"}"
case $SYSTEM in

2
debian/patches/series vendored Normal file
View file

@ -0,0 +1,2 @@
debian/0001-cc-builtins.patch
debian/0002-disable-sse.patch

10
debian/rules vendored
View file

@ -2,8 +2,12 @@
include /usr/share/dpkg/architecture.mk
ifeq ($(DEB_BUILD_ARCH),armel)
PLATFORM = --platform=armv7l
ifneq (,$(filter $(DEB_HOST_ARCH), armel x32))
PLATFORM = --platform=unknown
endif
ifeq ($(DEB_HOST_ARCH), i386)
PLATFORM = --disable-sse
endif
%:
@ -16,7 +20,7 @@ override_dh_auto_configure:
--includedir=/usr/include \
--mandir=/usr/share/man \
--cores=2 \
--disable-sse $(PLATFORM)
$(PLATFORM)
override_dh_auto_test:
$(MAKE) -j1 check