From b9056be3b4d0c481886fda91ba97db4a2c9ff750 Mon Sep 17 00:00:00 2001
From: Daniel Baumann <daniel@debian.org>
Date: Sun, 9 Feb 2025 07:42:22 +0100
Subject: [PATCH] Overwriting armhf platform target to fix FTBFS with newer GCC
 (Closes: #1009622).

Signed-off-by: Daniel Baumann <daniel@debian.org>
---
 debian/rules | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/debian/rules b/debian/rules
index fc4665d..9ed6221 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,11 @@ ifneq (,$(filter $(DEB_HOST_ARCH), armel x32))
 	PLATFORM = --platform=unknown
 endif
 
+ifeq ($(DEB_HOST_ARCH),armhf)
+	DEB_CFLAGS_MAINT_APPEND = -march=armv7-a+fp
+	export DEB_CFLAGS_MAINT_APPEND
+endif
+
 ifeq ($(DEB_HOST_ARCH), i386)
 	PLATFORM = --disable-sse
 endif