1
0
Fork 0
forgejo-cli/flake.nix
Daniel Baumann 80bb1315ee
Adding upstream version 0.2.0.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-11 12:14:08 +01:00

48 lines
1.2 KiB
Nix

{
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, utils }: utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
in
rec {
packages.forgejo-cli = pkgs.rustPlatform.buildRustPackage {
pname = "forgejo-cli";
version = "0.2.0";
src = pkgs.lib.cleanSource ./.;
cargoLock.lockFile = ./Cargo.lock;
nativeBuildInputs = with pkgs; [ pkg-config ];
buildInputs = with pkgs; [ openssl ];
meta = with pkgs.lib; {
description = "CLI tool for Forgejo";
homepage = "https://codeberg.org/Cyborus/forgejo-cli/";
license = with licenses; [ asl20 /* or */ mit ];
};
env = {
BUILD_TYPE = "flake";
};
};
packages.default = packages.forgejo-cli;
devShells.default = pkgs.mkShell {
inputsFrom = [ packages.default ];
nativeBuildInputs = with pkgs; [
cargo
rustc
];
# Required for rust-analyzer to work
RUST_SRC_PATH = "${pkgs.rustPlatform.rustcSrc}/library";
};
});
}