1
0
Fork 0
frr/tests/topotests/bgp_features/r1/ip_route_norib.json
Daniel Baumann a2d156806a
Merging upstream version 10.2.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-05 10:17:20 +01:00

281 lines
5.5 KiB
JSON

{
"192.168.0.1\/32":[
{
"prefix":"192.168.0.1\/32",
"protocol":"ospf",
"distance":110,
"metric":0,
"nexthops":[
{
"flags":3,
"directlyConnected":true,
"interfaceName":"lo",
"active":true,
"weight":1
}
]
},
{
"prefix":"192.168.0.1\/32",
"protocol":"connected",
"selected":true,
"destSelected":true,
"distance":0,
"metric":0,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"directlyConnected":true,
"interfaceName":"lo",
"active":true
}
]
}
],
"192.168.0.2\/32":[
{
"prefix":"192.168.0.2\/32",
"protocol":"ospf",
"selected":true,
"destSelected":true,
"distance":110,
"metric":10,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"ip":"192.168.1.2",
"afi":"ipv4",
"interfaceName":"r1-eth1",
"active":true,
"weight":1
}
]
}
],
"192.168.0.3\/32":[
{
"prefix":"192.168.0.3\/32",
"protocol":"ospf",
"selected":true,
"destSelected":true,
"distance":110,
"metric":10,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"ip":"192.168.3.2",
"afi":"ipv4",
"interfaceName":"r1-eth2",
"active":true,
"weight":1
}
]
}
],
"192.168.1.0\/24":[
{
"prefix":"192.168.1.0\/24",
"protocol":"ospf",
"distance":110,
"metric":10,
"nexthops":[
{
"flags":3,
"directlyConnected":true,
"interfaceName":"r1-eth1",
"active":true,
"weight":1
}
]
},
{
"prefix":"192.168.1.0\/24",
"protocol":"connected",
"selected":true,
"destSelected":true,
"distance":0,
"metric":0,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"directlyConnected":true,
"interfaceName":"r1-eth1",
"active":true
}
]
}
],
"192.168.2.0\/24":[
{
"prefix":"192.168.2.0\/24",
"protocol":"ospf",
"selected":true,
"destSelected":true,
"distance":110,
"metric":20,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"ip":"192.168.1.2",
"afi":"ipv4",
"interfaceName":"r1-eth1",
"active":true,
"weight":1
},
{
"flags":3,
"fib":true,
"ip":"192.168.3.2",
"afi":"ipv4",
"interfaceName":"r1-eth2",
"active":true,
"weight":1
}
]
}
],
"192.168.3.0\/24":[
{
"prefix":"192.168.3.0\/24",
"protocol":"ospf",
"distance":110,
"metric":10,
"nexthops":[
{
"flags":3,
"directlyConnected":true,
"interfaceName":"r1-eth2",
"active":true,
"weight":1
}
]
},
{
"prefix":"192.168.3.0\/24",
"protocol":"connected",
"selected":true,
"destSelected":true,
"distance":0,
"metric":0,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"directlyConnected":true,
"interfaceName":"r1-eth2",
"active":true
}
]
}
],
"192.168.6.0\/24":[
{
"prefix":"192.168.6.0\/24",
"protocol":"ospf",
"distance":110,
"metric":10,
"nexthops":[
{
"flags":3,
"directlyConnected":true,
"interfaceName":"r1-eth0",
"active":true,
"weight":1
}
]
},
{
"prefix":"192.168.6.0\/24",
"protocol":"connected",
"selected":true,
"destSelected":true,
"distance":0,
"metric":0,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"directlyConnected":true,
"interfaceName":"r1-eth0",
"active":true
}
]
}
],
"192.168.7.0\/24":[
{
"prefix":"192.168.7.0\/24",
"protocol":"ospf",
"selected":true,
"destSelected":true,
"distance":110,
"metric":20,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"ip":"192.168.1.2",
"afi":"ipv4",
"interfaceName":"r1-eth1",
"active":true,
"weight":1
}
]
}
],
"192.168.8.0\/24":[
{
"prefix":"192.168.8.0\/24",
"protocol":"ospf",
"selected":true,
"destSelected":true,
"distance":110,
"metric":20,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"ip":"192.168.3.2",
"afi":"ipv4",
"interfaceName":"r1-eth2",
"active":true,
"weight":1
}
]
}
],
"192.168.101.0\/24":[
{
"prefix":"192.168.101.0\/24",
"protocol":"connected",
"selected":true,
"destSelected":true,
"distance":0,
"metric":0,
"installed":true,
"nexthops":[
{
"flags":3,
"fib":true,
"directlyConnected":true,
"interfaceName":"r1-eth3",
"active":true
}
]
}
]
}