Moving debian specific patches to corresponding subdirectory.
Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
parent
50ebbc87ca
commit
34de096518
2 changed files with 7 additions and 14 deletions
|
@ -1,9 +1,6 @@
|
||||||
Forwarded: https://github.com/jorisroovers/gitlint/pull/104
|
Author: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
|
||||||
From 84145c703a25acad5f2378535c642c5abc299fbe Mon Sep 17 00:00:00 2001
|
Description: replace readfp with Python2 read_file function, to fix a test failure:
|
||||||
From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
|
https://github.com/jorisroovers/gitlint/pull/104
|
||||||
Date: Thu, 26 Sep 2019 10:48:14 +0200
|
|
||||||
Subject: [PATCH] replace readfp with Python2 read_file function, to fix a test
|
|
||||||
failure:
|
|
||||||
|
|
||||||
======================================================================
|
======================================================================
|
||||||
FAIL: test_config_file (test_cli.CLITests)
|
FAIL: test_config_file (test_cli.CLITests)
|
||||||
|
@ -21,10 +18,9 @@ AssertionError: "/<<PKGBUILDDIR>>/git[197 chars]od\n" != ''
|
||||||
gitlint/config.py | 3 +--
|
gitlint/config.py | 3 +--
|
||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/gitlint/config.py b/gitlint/config.py
|
diff -Naurp gitlint.orig/gitlint/config.py gitlint/gitlint/config.py
|
||||||
index fdc5e85..654523d 100644
|
--- gitlint.orig/gitlint/config.py
|
||||||
--- a/gitlint/config.py
|
+++ gitlint/gitlint/config.py
|
||||||
+++ b/gitlint/config.py
|
|
||||||
@@ -428,8 +428,7 @@ class LintConfigBuilder(object):
|
@@ -428,8 +428,7 @@ class LintConfigBuilder(object):
|
||||||
parser = ConfigParser()
|
parser = ConfigParser()
|
||||||
|
|
||||||
|
@ -35,6 +31,3 @@ index fdc5e85..654523d 100644
|
||||||
|
|
||||||
for section_name in parser.sections():
|
for section_name in parser.sections():
|
||||||
for option_name, option_value in parser.items(section_name):
|
for option_name, option_value in parser.items(section_name):
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
2
debian/patches/series
vendored
2
debian/patches/series
vendored
|
@ -1 +1 @@
|
||||||
0001-replace-readfp-with-Python2-read_file-function-to-fi.patch
|
debian/0001-fix-test-with-python3.patch
|
||||||
|
|
Loading…
Add table
Reference in a new issue