1
0
Fork 0

Removing fix-test-with-python3.patch, not needed anymore.

Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
Daniel Baumann 2025-02-13 06:01:03 +01:00
parent c6759e3393
commit 35c113268c
Signed by: daniel
GPG key ID: FBB4F0E80A80222F
3 changed files with 1 additions and 35 deletions

View file

@ -1,33 +0,0 @@
Author: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
Description: replace readfp with Python2 read_file function, to fix a test failure:
https://github.com/jorisroovers/gitlint/pull/104
======================================================================
FAIL: test_config_file (test_cli.CLITests)
Test for --config option
----------------------------------------------------------------------
Traceback (most recent call last):
File "/usr/lib/python3.7/unittest/mock.py", line 1248, in patched
return func(*args, **keywargs)
File "/<<PKGBUILDDIR>>/gitlint/tests/test_cli.py", line 372, in test_config_file
self.assertEqual(result.output, "")
AssertionError: "/<<PKGBUILDDIR>>/git[197 chars]od\n" != ''
- /<<PKGBUILDDIR>>/gitlint/config.py:366: DeprecationWarning: This method will be removed in future versions. Use 'parser.read_file()' instead.
- parser.readfp(config_file, filename) # pylint: disable=deprecated-method
---
gitlint/config.py | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff -Naurp gitlint.orig/gitlint/config.py gitlint/gitlint/config.py
--- gitlint.orig/gitlint/config.py
+++ gitlint/gitlint/config.py
@@ -428,8 +428,7 @@ class LintConfigBuilder(object):
parser = ConfigParser()
with io.open(filename, encoding=DEFAULT_ENCODING) as config_file:
- # readfp() is deprecated in python 3.2+, but compatible with 2.7
- parser.readfp(config_file, filename) # pylint: disable=deprecated-method
+ parser.read_file(config_file)
for section_name in parser.sections():
for option_name, option_value in parser.items(section_name):

View file

@ -1,2 +1 @@
debian/0001-fix-test-with-python3.patch
debian/0002-python3-hook.patch
debian/0001-python3-hook.patch