1
0
Fork 0
pre-commit/tests/languages/fail_test.py
Daniel Baumann c4c52947de
Merging upstream version 3.1.0.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-09 21:38:08 +01:00

14 lines
329 B
Python

from __future__ import annotations
from pre_commit.languages import fail
from testing.language_helpers import run_language
def test_fail_hooks(tmp_path):
ret = run_language(
tmp_path,
fail,
'watch out for',
file_args=('bunnies',),
)
assert ret == (1, b'watch out for\n\nbunnies\n')