1
0
Fork 0
pre-commit/tests/languages/script_test.py
Daniel Baumann c4c52947de
Merging upstream version 3.1.0.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-09 21:38:08 +01:00

14 lines
443 B
Python

from __future__ import annotations
from pre_commit.languages import script
from pre_commit.util import make_executable
from testing.language_helpers import run_language
def test_script_language(tmp_path):
exe = tmp_path.joinpath('main')
exe.write_text('#!/usr/bin/env bash\necho hello hello world\n')
make_executable(exe)
expected = (0, b'hello hello world\n')
assert run_language(tmp_path, script, 'main') == expected