Building without -march=native (Closes: #1071076).
Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
parent
fc2a78a47a
commit
96071ea9e9
2 changed files with 20 additions and 0 deletions
19
debian/patches/debian/0001-march.patch
vendored
Normal file
19
debian/patches/debian/0001-march.patch
vendored
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
Author: Daniel Baumann <daniel.baumann@progress-linux.org>
|
||||||
|
Description: Building without -march=native (Closes: #1071076).
|
||||||
|
|
||||||
|
diff -Naurp inotify-info.orig/Makefile inotify-info/Makefile
|
||||||
|
--- inotify-info.orig/Makefile
|
||||||
|
+++ inotify-info/Makefile
|
||||||
|
@@ -33,10 +33,10 @@ ifneq ($(COMPILER),clang)
|
||||||
|
WARNINGS += -Wsuggest-attribute=format -Wall
|
||||||
|
endif
|
||||||
|
|
||||||
|
-CFLAGS = $(WARNINGS) -march=native -fno-exceptions -gdwarf-4 -g2 -ggnu-pubnames -gsplit-dwarf
|
||||||
|
+CFLAGS = $(WARNINGS) -fno-exceptions -gdwarf-4 -g2 -ggnu-pubnames -gsplit-dwarf
|
||||||
|
CFLAGS += -D_LARGEFILE64_SOURCE=1 -D_FILE_OFFSET_BITS=64
|
||||||
|
CXXFLAGS = -fno-rtti -Woverloaded-virtual
|
||||||
|
-LDFLAGS = -march=native -gdwarf-4 -g2 -Wl,--build-id=sha1
|
||||||
|
+LDFLAGS = -gdwarf-4 -g2 -Wl,--build-id=sha1
|
||||||
|
LIBS = -Wl,--no-as-needed -lm -ldl -lpthread -lstdc++
|
||||||
|
|
||||||
|
CFILES = \
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
|
@ -1 +1,2 @@
|
||||||
|
debian/0001-march.patch
|
||||||
debian/0001-dwz.patch
|
debian/0001-dwz.patch
|
||||||
|
|
Loading…
Add table
Reference in a new issue