1
0
Fork 0
inotify-info/debian/patches/debian/0001-march.patch
Daniel Baumann 96071ea9e9
Building without -march=native (Closes: #1071076).
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-05 15:18:08 +01:00

19 lines
795 B
Diff

Author: Daniel Baumann <daniel.baumann@progress-linux.org>
Description: Building without -march=native (Closes: #1071076).
diff -Naurp inotify-info.orig/Makefile inotify-info/Makefile
--- inotify-info.orig/Makefile
+++ inotify-info/Makefile
@@ -33,10 +33,10 @@ ifneq ($(COMPILER),clang)
WARNINGS += -Wsuggest-attribute=format -Wall
endif
-CFLAGS = $(WARNINGS) -march=native -fno-exceptions -gdwarf-4 -g2 -ggnu-pubnames -gsplit-dwarf
+CFLAGS = $(WARNINGS) -fno-exceptions -gdwarf-4 -g2 -ggnu-pubnames -gsplit-dwarf
CFLAGS += -D_LARGEFILE64_SOURCE=1 -D_FILE_OFFSET_BITS=64
CXXFLAGS = -fno-rtti -Woverloaded-virtual
-LDFLAGS = -march=native -gdwarf-4 -g2 -Wl,--build-id=sha1
+LDFLAGS = -gdwarf-4 -g2 -Wl,--build-id=sha1
LIBS = -Wl,--no-as-needed -lm -ldl -lpthread -lstdc++
CFILES = \