1
0
Fork 0

Refreshing no-Werror.patch.

Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
Daniel Baumann 2025-02-14 06:02:02 +01:00
parent 319ca976d2
commit 5b11395853
Signed by: daniel
GPG key ID: FBB4F0E80A80222F
3 changed files with 19 additions and 25 deletions

View file

@ -1,24 +0,0 @@
From: martin f. krafft <madduck@debian.org>
Subject: Remove -Werror from compiler flags
-Werror seems like a bad idea on released/packaged code because a toolchain
update (introducing new warnings) could break the build. We'll let upstream
use it to beautify the code, but remove it for out builds.
Signed-off-by: martin f. krafft <madduck@debian.org>
---
Makefile | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
--- a/Makefile
+++ b/Makefile
@@ -50,7 +50,7 @@ ifeq ($(origin CC),default)
CC := $(CROSS_COMPILE)gcc
endif
CXFLAGS ?= -ggdb
-CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
+CWFLAGS = -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
ifdef WARN_UNUSED
CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O3
endif

View file

@ -0,0 +1,18 @@
Author: Martin F. Krafft <madduck@debian.org>
Description: Remove -Werror from compiler flags.
-Werror seems like a bad idea on released/packaged code because a toolchain
update (introducing new warnings) could break the build. We'll let upstream
use it to beautify the code, but remove it for out builds.
diff -Naurp mdadm.orig/Makefile mdadm/Makefile
--- mdadm.orig/Makefile
+++ mdadm/Makefile
@@ -50,7 +50,7 @@ ifeq ($(origin CC),default)
CC := $(CROSS_COMPILE)gcc
endif
CXFLAGS ?= -ggdb
-CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
+CWFLAGS = -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
ifdef WARN_UNUSED
CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O3
endif

View file

@ -4,5 +4,5 @@ debian/0003-host-name-in-default-mailfrom.patch
debian/0004-exit-gracefully-when-md-device-not-found.patch
debian/0005-sha1-includes.patch
debian/0006-readlink-path.patch
debian-no-Werror.diff
debian/0007-no-Werror.patch
test-installed.patch