1
0
Fork 0

Adding slightly adjusted patch from Chris Hofstaedtler <zeha@debian.org> to install into usrmerged layout (Closes: #1073726).

Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
Daniel Baumann 2025-02-14 06:34:56 +01:00
parent 51c9310fca
commit aeb5c81ce4
Signed by: daniel
GPG key ID: FBB4F0E80A80222F
7 changed files with 42 additions and 5 deletions

View file

@ -0,0 +1,19 @@
Author: Chris Hofstaedtler <zeha@debian.org>
Description: Patch Makefile to use pkg-config systemd to discover systemd unit dir.
diff -Naurp mdadm.orig/Makefile mdadm/Makefile
--- mdadm.orig/Makefile
+++ mdadm/Makefile
@@ -106,7 +106,11 @@ MAP_PATH = $(MAP_DIR)/$(MAP_FILE)
MDMON_DIR = $(RUN_DIR)
# place for autoreplace cookies
FAILED_SLOTS_DIR = $(RUN_DIR)/failed-slots
-SYSTEMD_DIR=/lib/systemd/system
+SYSTEMD_DIR := $(shell $(PKG_CONFIG) --variable=systemdsystemunitdir systemd 2>/dev/null)
+ifndef SYSTEMD_DIR
+ SYSTEMD_DIR=/lib/systemd/system
+endif
+
LIB_DIR=/usr/libexec/mdadm
COROSYNC:=$(shell [ -d /usr/include/corosync ] || echo -DNO_COROSYNC)

View file

@ -0,0 +1,15 @@
Author: Chris Hofstaedtler <zeha@debian.org>
Description: Patch Makefile to use /usr/sbin instead of /sbin.
diff -Naurp mdadm.orig/Makefile mdadm/Makefile
--- mdadm.orig/Makefile
+++ mdadm/Makefile
@@ -146,7 +150,7 @@ endif
INSTALL = /usr/bin/install
DESTDIR =
-BINDIR = /sbin
+BINDIR = /usr/sbin
MANDIR = /usr/share/man
MAN4DIR = $(MANDIR)/man4
MAN5DIR = $(MANDIR)/man5

View file

@ -9,3 +9,5 @@ debian/0008-test-installed.patch
debian/0009-randomize-timers.patch
debian/0010-systemd-honor-debconf-daily-scan.patch
debian/0011-mdcheck-fix-empty-spaces-in-timer-unit-files.patch
debian/0012-systemd-directory.patch
debian/0013-bin-directory.patch