1
0
Fork 0
mdadm/tests/00raid5-zero
Daniel Baumann b8d8e3b147
Merging upstream version 4.2+20230313.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-14 06:05:07 +01:00

12 lines
365 B
Text

if mdadm -CfR $md0 -l 5 -n3 $dev0 $dev1 $dev2 --write-zeroes ; then
check nosync
echo check > /sys/block/md0/md/sync_action;
check wait
elif grep "zeroing [^ ]* failed: Operation not supported" \
$targetdir/stderr; then
echo "write-zeros not supported, skipping"
else
echo >&2 "ERROR: mdadm return failure without not supported message"
exit 1
fi