12 lines
365 B
Text
12 lines
365 B
Text
|
|
if mdadm -CfR $md0 -l 5 -n3 $dev0 $dev1 $dev2 --write-zeroes ; then
|
|
check nosync
|
|
echo check > /sys/block/md0/md/sync_action;
|
|
check wait
|
|
elif grep "zeroing [^ ]* failed: Operation not supported" \
|
|
$targetdir/stderr; then
|
|
echo "write-zeros not supported, skipping"
|
|
else
|
|
echo >&2 "ERROR: mdadm return failure without not supported message"
|
|
exit 1
|
|
fi
|