1
0
Fork 0
mdadm/tests/07autodetect
Daniel Baumann dfe7ded19c
Merging upstream version 4.4.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-14 06:38:13 +01:00

30 lines
610 B
Text

#
# Test in-kernel autodetect.
# Create a partitionable array on each of two devices,
# put a partition on each, create an array, and see if we can
# use autodetect to restart the array.
[if lsmod | grep md_mod > /dev/null 2>&1] || skip "md is a module - cannot test autodetect"
mdadm -CR -e 0 $mdp0 -l0 -f -n1 $dev0
mdadm -CR -e 0 $mdp1 -l0 -f -n1 $dev1
udevadm settle
sfdisk $mdp0 >&2 << END
,,FD
END
sfdisk $mdp1 >&2 << END
,,FD
END
udevadm settle
mdadm -CR -e 0 $md0 -l1 -n2 ${mdp0}p1 ${mdp1}p1
sleep 2
check resync
check raid1
check wait
mdadm -S $md0
mdadm --auto-detect
check raid1
mdadm -Ss
exit 0