diff --git a/.github/dependabot.yml b/.github/dependabot.yml
new file mode 100644
index 0000000..23c4cb3
--- /dev/null
+++ b/.github/dependabot.yml
@@ -0,0 +1,7 @@
+---
+version: 2
+updates:
+ - package-ecosystem: "github-actions"
+ directory: "/"
+ schedule:
+ interval: "weekly"
diff --git a/.github/workflows/meson.yml b/.github/workflows/meson.yml
index 0d6350f..c49470b 100644
--- a/.github/workflows/meson.yml
+++ b/.github/workflows/meson.yml
@@ -9,14 +9,16 @@ on:
workflow_dispatch:
jobs:
- meson-build:
+ build-disto:
runs-on: ubuntu-latest
steps:
- name: install libraries
run: sudo apt-get install libjson-c-dev libhugetlbfs-dev
- - uses: actions/checkout@v2
- - uses: actions/setup-python@v1
+ - uses: actions/checkout@v3
+ - uses: actions/setup-python@v4
+ with:
+ python-version: '3.x'
# - name: install python dependencies
# run: |
# python -m pip install --upgrade pip
@@ -25,3 +27,35 @@ jobs:
with:
setup-options: --werror
action: build
+
+ build-fallback:
+ runs-on: ubuntu-latest
+ steps:
+ - name: install libraries
+ run: sudo apt-get install -y libpam-dev libcap-ng-dev
+ - uses: actions/checkout@v3
+ - uses: actions/setup-python@v4
+ with:
+ python-version: '3.x'
+ - uses: BSFishy/meson-build@v1.0.3
+ with:
+ setup-options: --werror -Duuid:werror=false --wrap-mode=forcefallback
+ options: --verbose
+ action: build
+ meson-version: 0.61.2
+
+ build-static:
+ runs-on: ubuntu-latest
+ steps:
+ - name: install libraries
+ run: sudo apt-get install -y libpam-dev libcap-ng-dev
+ - uses: actions/checkout@v3
+ - uses: actions/setup-python@v4
+ with:
+ python-version: '3.x'
+ - uses: BSFishy/meson-build@v1.0.3
+ with:
+ setup-options: --werror -Duuid:werror=false --wrap-mode=forcefallback --default-library=static
+ options: --verbose
+ action: build
+ meson-version: 0.61.2
diff --git a/.github/workflows/release.yml b/.github/workflows/release.yml
new file mode 100644
index 0000000..db84ef5
--- /dev/null
+++ b/.github/workflows/release.yml
@@ -0,0 +1,19 @@
+name: Releases
+
+on:
+ push:
+ branches: [ master ]
+ tags:
+ - '**'
+
+jobs:
+ build:
+ runs-on: ubuntu-latest
+ if: startsWith(github.ref, 'refs/tags/v')
+ permissions:
+ contents: write
+ steps:
+ - uses: actions/checkout@v2
+ - uses: ncipollo/release-action@v1
+ with:
+ token: ${{ secrets.GITHUB_TOKEN }}
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
index 3b7f55f..cde8527 100644
--- a/CONTRIBUTING.md
+++ b/CONTRIBUTING.md
@@ -7,7 +7,11 @@ Contributions and new ideas are most welcome!
**NOTE: If you do decide to implement code changes and contribute them,
please make sure you agree your contribution can be made available
-under the [GPLv2-style License used for the NVMe CLI](https://github.com/linux-nvme/nvme-cli/blob/master/LICENSE).**
+under the [GPLv2-style License used for the NVMe CLI](https://github.com/linux-nvme/nvme-cli/blob/master/LICENSE).
+(SPDX-License-Identifier: GPL-2.0-or-later)**
+
+Because there are a few files licensed under GPL-2.0-only, the whole
+project is tagged as GPL-2.0-only and not as GPL-2.0-or-later.
### Code Contributions
diff --git a/Documentation/cmd-plugins.txt b/Documentation/cmd-plugins.txt
index 4e66cf1..2ab6c68 100644
--- a/Documentation/cmd-plugins.txt
+++ b/Documentation/cmd-plugins.txt
@@ -65,7 +65,7 @@ linknvme:nvme-transcend-badblock[1]::
Retrieve Transcend NVMe device's bad blocks
linknvme:nvme-transcend-healthvalue[1]::
- Use NVMe SMART table to analyse the health value of Transcend device
+ Use NVMe SMART table to analyze the health value of Transcend device
linknvme:nvme-virtium-show-identify[1]::
Show a complete detail of identify device information in json format
diff --git a/Documentation/cmds-main.txt b/Documentation/cmds-main.txt
index ab8ee3b..58a8094 100644
--- a/Documentation/cmds-main.txt
+++ b/Documentation/cmds-main.txt
@@ -44,7 +44,7 @@ linknvme:nvme-smart-log[1]::
Retrieve Smart Log
linknvme:nvme-ana-log[1]::
- Retreive ANA(Asymmetric Namespace Access) Log
+ Retrieve ANA(Asymmetric Namespace Access) Log
linknvme:nvme-endurance-log[1]::
Retrieve endurance Log
@@ -236,7 +236,7 @@ linknvme:nvme-nvm-id-ns-lba-format[1]::
NVMe Identify Namespace NVM Command Set for the specified LBA Format index
linknvme:nvme-persistent-event-log[1]::
- Retrieve Presistent Event Log
+ Retrieve Persistent Event Log
linknvme:nvme-predictable-lat-log[1]::
Retrieve Predictable Latency per Nvmset Log
diff --git a/Documentation/meson.build b/Documentation/meson.build
index a12eec4..a47c27f 100644
--- a/Documentation/meson.build
+++ b/Documentation/meson.build
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
adoc_sources = [
'nvme',
'nvme-admin-passthru',
@@ -114,6 +116,7 @@ adoc_sources = [
'nvme-wdc-clear-assert-dump',
'nvme-wdc-clear-fw-activate-history',
'nvme-wdc-clear-pcie-correctable-errors',
+ 'nvme-wdc-cloud-boot-SSD-version',
'nvme-wdc-cloud-SSD-plugin-version',
'nvme-wdc-drive-essentials',
'nvme-wdc-drive-log',
@@ -131,9 +134,12 @@ adoc_sources = [
'nvme-wdc-namespace-resize',
'nvme-wdc-purge',
'nvme-wdc-purge-monitor',
+ 'nvme-wdc-vs-cloud-log',
+ 'nvme-wdc-vs-device-waf',
'nvme-wdc-vs-drive-info',
'nvme-wdc-vs-error-reason-identifier',
'nvme-wdc-vs-fw-activate-history',
+ 'nvme-wdc-vs-hw-rev-log',
'nvme-wdc-vs-internal-log',
'nvme-wdc-vs-nand-stats',
'nvme-wdc-vs-smart-add-log',
@@ -168,7 +174,7 @@ if want_docs != 'false'
mandir = join_paths(get_option('mandir'), 'man1')
htmldir = join_paths(get_option('htmldir'), 'nvme')
- asciidoctor = find_program('asciidoc', required : false)
+ asciidoctor = find_program('asciidoc', required: get_option('docs-build'))
if want_docs_build and asciidoctor.found()
# Build documentation before installing
diff --git a/Documentation/nvme-admin-passthru.1 b/Documentation/nvme-admin-passthru.1
index 1beb822..45ed0ea 100644
--- a/Documentation/nvme-admin-passthru.1
+++ b/Documentation/nvme-admin-passthru.1
@@ -2,12 +2,12 @@
.\" Title: nvme-admin-passthru
.\" Author: [FIXME: author] [see http://www.docbook.org/tdg5/en/html/author]
.\" Generator: DocBook XSL Stylesheets vsnapshot
-.\" Date: 04/08/2022
+.\" Date: 07/14/2022
.\" Manual: NVMe Manual
.\" Source: NVMe
.\" Language: English
.\"
-.TH "NVME\-ADMIN\-PASSTHR" "1" "04/08/2022" "NVMe" "NVMe Manual"
+.TH "NVME\-ADMIN\-PASSTHR" "1" "07/14/2022" "NVMe" "NVMe Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/Documentation/nvme-admin-passthru.html b/Documentation/nvme-admin-passthru.html
index b6b7675..c1c31c2 100644
--- a/Documentation/nvme-admin-passthru.html
+++ b/Documentation/nvme-admin-passthru.html
@@ -4,7 +4,7 @@
-
+
nvme-admin-passthru(1)
+
+
+
+
+
+
+
SYNOPSIS
+
+
+
nvme wdc cloud-boot-SSD-version <device>
+
+
+
+
+
+
DESCRIPTION
+
+
For the NVMe device given, this command displays the current Cloud Hyperscale
+Boot Version (if supported by the device).
+
The <device> parameter is mandatory NVMe character device (ex: /dev/nvme0).
+
On success it returns 0, error code otherwise.
+
+
+
+
+
NVME
+
+
Part of the nvme-user suite.
+
+
+
+
+
+
+
diff --git a/Documentation/nvme-wdc-cloud-boot-SSD-version.txt b/Documentation/nvme-wdc-cloud-boot-SSD-version.txt
new file mode 100644
index 0000000..a3f105e
--- /dev/null
+++ b/Documentation/nvme-wdc-cloud-boot-SSD-version.txt
@@ -0,0 +1,33 @@
+nvme-wdc-cloud-boot-SSD-version(1)
+==================================
+
+NAME
+----
+nvme-wdc-cloud-boot-SSD-version - Display WDC plugin Cloud Boot SSD Version
+
+SYNOPSIS
+--------
+[verse]
+'nvme wdc cloud-boot-SSD-version'
+
+DESCRIPTION
+-----------
+
+For the NVMe device given, this command displays the current Cloud Hyperscale
+Boot Version (if supported by the device).
+
+The parameter is mandatory NVMe character device (ex: /dev/nvme0).
+
+On success it returns 0, error code otherwise.
+
+EXAMPLES
+--------
+* Displays the cloud boot ssd version for the device:
++
+------------
+# nvme wdc cloud-boot-SSD-version /dev/nvme0
+------------
+
+NVME
+----
+Part of the nvme-user suite.
diff --git a/Documentation/nvme-wdc-drive-essentials.1 b/Documentation/nvme-wdc-drive-essentials.1
index e481ec2..928ae4f 100644
--- a/Documentation/nvme-wdc-drive-essentials.1
+++ b/Documentation/nvme-wdc-drive-essentials.1
@@ -2,12 +2,12 @@
.\" Title: nvme-wdc-drive-essentials
.\" Author: [FIXME: author] [see http://www.docbook.org/tdg5/en/html/author]
.\" Generator: DocBook XSL Stylesheets vsnapshot
-.\" Date: 04/08/2022
+.\" Date: 07/14/2022
.\" Manual: NVMe Manual
.\" Source: NVMe
.\" Language: English
.\"
-.TH "NVME\-WDC\-DRIVE\-ES" "1" "04/08/2022" "NVMe" "NVMe Manual"
+.TH "NVME\-WDC\-DRIVE\-ES" "1" "07/14/2022" "NVMe" "NVMe Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/Documentation/nvme-wdc-drive-essentials.html b/Documentation/nvme-wdc-drive-essentials.html
index d760965..2835cdc 100644
--- a/Documentation/nvme-wdc-drive-essentials.html
+++ b/Documentation/nvme-wdc-drive-essentials.html
@@ -4,7 +4,7 @@
-
+
nvme-wdc-drive-essentials(1)
+
+
+
+
+
+
+
SYNOPSIS
+
+
+
nvme wdc vs-cloud-log <device> [--output-format=<normal|json> -o <normal|json>]
+ [--namespace-id=<nsid> | -n <nsid>]
+
+
+
+
+
+
DESCRIPTION
+
+
For the NVMe device given, send a Vendor Unique WDC vs-cloud-log command and
+provide the smart/health log.
+
The <device> parameter is mandatory and may be either the NVMe character
+device (ex: /dev/nvme0) or block device (ex: /dev/nvme0n1).
+
This will only work on WDC devices supporting this feature.
+Results for any other device are undefined.
+
On success it returns 0, error code otherwise.
+
+
+
+
OPTIONS
+
+
+-
+-o <format>
+
+-
+--output-format=<format>
+
+-
+
+ Set the reporting format to normal, or
+ json. Only one output format can be used at a time.
+ Default is normal.
+
+
+-
+-n <nsid>
+
+-
+--namespace-id=<nsid>
+
+-
+
+ Sets the command’s nsid value to the given nsid. Defaults to
+ 0xffffffff if not given. This option may not affect anything
+ depending on the log page, which may or may not be specific to
+ a namespace.
+
+
+
+
+
+
+
+
NVME
+
+
Part of the nvme-user suite.
+
+
+
+
+
+
+
diff --git a/Documentation/nvme-wdc-vs-cloud-log.txt b/Documentation/nvme-wdc-vs-cloud-log.txt
new file mode 100644
index 0000000..9eeee42
--- /dev/null
+++ b/Documentation/nvme-wdc-vs-cloud-log.txt
@@ -0,0 +1,52 @@
+nvme-wdc-vs-cloud-log(1)
+========================
+
+NAME
+----
+nvme-wdc-vs-cloud-log - Send NVMe WDC vs-cloud-log Vendor Unique Command, return result
+
+SYNOPSIS
+--------
+[verse]
+'nvme wdc vs-cloud-log' [--output-format= -o ]
+ [--namespace-id= | -n ]
+
+DESCRIPTION
+-----------
+For the NVMe device given, send a Vendor Unique WDC vs-cloud-log command and
+provide the smart/health log.
+
+The parameter is mandatory and may be either the NVMe character
+device (ex: /dev/nvme0) or block device (ex: /dev/nvme0n1).
+
+This will only work on WDC devices supporting this feature.
+Results for any other device are undefined.
+
+On success it returns 0, error code otherwise.
+
+OPTIONS
+-------
+-o ::
+--output-format=::
+ Set the reporting format to 'normal', or
+ 'json'. Only one output format can be used at a time.
+ Default is normal.
+
+-n ::
+--namespace-id=::
+ Sets the command's nsid value to the given nsid. Defaults to
+ 0xffffffff if not given. This option may not affect anything
+ depending on the log page, which may or may not be specific to
+ a namespace.
+
+EXAMPLES
+--------
+* Has the program issue WDC vs-cloud-log Vendor Unique Command :
++
+------------
+# nvme wdc vs-cloud-log /dev/nvme0
+------------
+
+NVME
+----
+Part of the nvme-user suite.
diff --git a/Documentation/nvme-wdc-vs-device-waf.1 b/Documentation/nvme-wdc-vs-device-waf.1
new file mode 100644
index 0000000..76235e8
--- /dev/null
+++ b/Documentation/nvme-wdc-vs-device-waf.1
@@ -0,0 +1,84 @@
+'\" t
+.\" Title: nvme-wdc-vs-device-waf
+.\" Author: [FIXME: author] [see http://www.docbook.org/tdg5/en/html/author]
+.\" Generator: DocBook XSL Stylesheets vsnapshot
+.\" Date: 07/14/2022
+.\" Manual: NVMe Manual
+.\" Source: NVMe
+.\" Language: English
+.\"
+.TH "NVME\-WDC\-VS\-DEVIC" "1" "07/14/2022" "NVMe" "NVMe Manual"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+nvme-wdc-vs-device-waf \- Calculates the device write amplification factor and prints both TLC and SLC results
+.SH "SYNOPSIS"
+.sp
+.nf
+\fInvme wdc vs\-device\-waf\fR [\-\-output\-format= \-o ]
+ [\-\-namespace\-id= | \-n ]
+.fi
+.SH "DESCRIPTION"
+.sp
+For the NVMe device given, calculates the device TLC and SLC write amplification factor\&.
+.sp
+The parameter is mandatory and may be either the NVMe character device (ex: /dev/nvme0) or block device (ex: /dev/nvme0n1)\&.
+.sp
+This will only work on WDC devices supporting this feature\&. Results for any other device are undefined\&.
+.sp
+On success it returns 0, error code otherwise\&.
+.SH "OPTIONS"
+.PP
+\-o , \-\-output\-format=
+.RS 4
+Set the reporting format to
+\fInormal\fR, or
+\fIjson\fR\&. Only one output format can be used at a time\&. Default is normal\&.
+.RE
+.PP
+\-n , \-\-namespace\-id=
+.RS 4
+Sets the command\(cqs nsid value to the given nsid\&. Defaults to 0xffffffff if not given\&. This option may not affect anything depending on the log page, which may or may not be specific to a namespace\&.
+.RE
+.SH "EXAMPLES"
+.sp
+.RS 4
+.ie n \{\
+\h'-04'\(bu\h'+03'\c
+.\}
+.el \{\
+.sp -1
+.IP \(bu 2.3
+.\}
+Has the program issue WDC vs\-device\-waf plugin Command :
+.sp
+.if n \{\
+.RS 4
+.\}
+.nf
+# nvme wdc vs\-device\-waf /dev/nvme0
+.fi
+.if n \{\
+.RE
+.\}
+.RE
+.SH "NVME"
+.sp
+Part of the nvme\-user suite\&.
diff --git a/Documentation/nvme-wdc-vs-device-waf.html b/Documentation/nvme-wdc-vs-device-waf.html
new file mode 100644
index 0000000..93075ab
--- /dev/null
+++ b/Documentation/nvme-wdc-vs-device-waf.html
@@ -0,0 +1,835 @@
+
+
+
+
+
+
+nvme-wdc-vs-device-waf(1)
+
+
+
+
+
+
+
+
SYNOPSIS
+
+
+
nvme wdc vs-device-waf <device> [--output-format=<normal|json> -o <normal|json>]
+ [--namespace-id=<nsid> | -n <nsid>]
+
+
+
+
+
+
DESCRIPTION
+
+
For the NVMe device given, calculates the device TLC and SLC write
+amplification factor.
+
The <device> parameter is mandatory and may be either the NVMe character
+device (ex: /dev/nvme0) or block device (ex: /dev/nvme0n1).
+
This will only work on WDC devices supporting this feature.
+Results for any other device are undefined.
+
On success it returns 0, error code otherwise.
+
+
+
+
OPTIONS
+
+
+-
+-o <format>
+
+-
+--output-format=<format>
+
+-
+
+ Set the reporting format to normal, or
+ json. Only one output format can be used at a time.
+ Default is normal.
+
+
+-
+-n <nsid>
+
+-
+--namespace-id=<nsid>
+
+-
+
+ Sets the command’s nsid value to the given nsid. Defaults to
+ 0xffffffff if not given. This option may not affect anything
+ depending on the log page, which may or may not be specific to
+ a namespace.
+
+
+
+
+
+
+
+
NVME
+
+
Part of the nvme-user suite.
+
+
+
+
+
+
+
diff --git a/Documentation/nvme-wdc-vs-device-waf.txt b/Documentation/nvme-wdc-vs-device-waf.txt
new file mode 100644
index 0000000..55095a4
--- /dev/null
+++ b/Documentation/nvme-wdc-vs-device-waf.txt
@@ -0,0 +1,53 @@
+nvme-wdc-vs-device-waf(1)
+=========================
+
+NAME
+----
+nvme-wdc-vs-device-waf - Calculates the device write amplification factor and
+prints both TLC and SLC results
+
+SYNOPSIS
+--------
+[verse]
+'nvme wdc vs-device-waf' [--output-format= -o ]
+ [--namespace-id= | -n ]
+
+DESCRIPTION
+-----------
+For the NVMe device given, calculates the device TLC and SLC write
+amplification factor.
+
+The parameter is mandatory and may be either the NVMe character
+device (ex: /dev/nvme0) or block device (ex: /dev/nvme0n1).
+
+This will only work on WDC devices supporting this feature.
+Results for any other device are undefined.
+
+On success it returns 0, error code otherwise.
+
+OPTIONS
+-------
+-o ::
+--output-format=::
+ Set the reporting format to 'normal', or
+ 'json'. Only one output format can be used at a time.
+ Default is normal.
+
+-n ::
+--namespace-id=::
+ Sets the command's nsid value to the given nsid. Defaults to
+ 0xffffffff if not given. This option may not affect anything
+ depending on the log page, which may or may not be specific to
+ a namespace.
+
+EXAMPLES
+--------
+* Has the program issue WDC vs-device-waf plugin Command :
++
+------------
+# nvme wdc vs-device-waf /dev/nvme0
+------------
+
+NVME
+----
+Part of the nvme-user suite.
diff --git a/Documentation/nvme-wdc-vs-drive-info.1 b/Documentation/nvme-wdc-vs-drive-info.1
index 638188c..518a89f 100644
--- a/Documentation/nvme-wdc-vs-drive-info.1
+++ b/Documentation/nvme-wdc-vs-drive-info.1
@@ -2,12 +2,12 @@
.\" Title: nvme-wdc-vs-drive-info
.\" Author: [FIXME: author] [see http://www.docbook.org/tdg5/en/html/author]
.\" Generator: DocBook XSL Stylesheets vsnapshot
-.\" Date: 04/08/2022
+.\" Date: 07/14/2022
.\" Manual: NVMe Manual
.\" Source: NVMe
.\" Language: English
.\"
-.TH "NVME\-WDC\-VS\-DRIVE" "1" "04/08/2022" "NVMe" "NVMe Manual"
+.TH "NVME\-WDC\-VS\-DRIVE" "1" "07/14/2022" "NVMe" "NVMe Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
@@ -45,11 +45,17 @@ This will only work on WDC devices supporting this feature\&. Results for any ot
On success it returns 0, error code otherwise\&.
.SH "OUTPUT EXPLANATION"
.sp
-There are 2 fields returned from this command:
+There are several different fields returned from this command depending on the drive:
.sp
Drive HW Revision
.sp
FTL Unit Size
+.sp
+Customer Serial Number
+.sp
+HyperScale Boot Version
+.sp
+TCG Device Ownership
.SH "EXAMPLE"
.sp
# nvme wdc vs\-drive\-info /dev/nvme0
diff --git a/Documentation/nvme-wdc-vs-drive-info.html b/Documentation/nvme-wdc-vs-drive-info.html
index afb487a..f060e21 100644
--- a/Documentation/nvme-wdc-vs-drive-info.html
+++ b/Documentation/nvme-wdc-vs-drive-info.html
@@ -4,7 +4,7 @@
-
+
nvme-wdc-vs-drive-info(1)
+
+
+
+
+
+
+
SYNOPSIS
+
+
+
nvme wdc vs-hw-rev-log <device> [--output-format=<normal|json> -o <normal|json>]
+ [--namespace-id=<nsid> | -n <nsid>]
+
+
+
+
+
+
DESCRIPTION
+
+
For the NVMe device given, retrieves and formats the Vendor Unique WDC hw revision log page.
+
The <device> parameter is mandatory and may be either the NVMe character
+device (ex: /dev/nvme0) or block device (ex: /dev/nvme0n1).
+
This will only work on WDC devices supporting this feature.
+Results for any other device are undefined.
+
On success it returns 0, error code otherwise.
+
+
+
+
OPTIONS
+
+
+-
+-o <format>
+
+-
+--output-format=<format>
+
+-
+
+ Set the reporting format to normal, or
+ json. Only one output format can be used at a time.
+ Default is normal.
+
+
+-
+-n <nsid>
+
+-
+--namespace-id=<nsid>
+
+-
+
+ Sets the command’s nsid value to the given nsid. Defaults to
+ 0xffffffff if not given. This option may not affect anything
+ depending on the log page, which may or may not be specific to
+ a namespace.
+
+
+
+
+
+
+
+
NVME
+
+
Part of the nvme-user suite.
+
+
+
+
+
+
+
diff --git a/Documentation/nvme-wdc-vs-hw-rev-log.txt b/Documentation/nvme-wdc-vs-hw-rev-log.txt
new file mode 100644
index 0000000..c5335d9
--- /dev/null
+++ b/Documentation/nvme-wdc-vs-hw-rev-log.txt
@@ -0,0 +1,51 @@
+nvme-wdc-vs-hw-rev-log(1)
+=========================
+
+NAME
+----
+nvme-wdc-vs-hw-rev-log - Send NVMe WDC vs-hw-rev-log Vendor Unique Command, return result
+
+SYNOPSIS
+--------
+[verse]
+'nvme wdc vs-hw-rev-log' [--output-format= -o ]
+ [--namespace-id= | -n ]
+
+DESCRIPTION
+-----------
+For the NVMe device given, retrieves and formats the Vendor Unique WDC hw revision log page.
+
+The parameter is mandatory and may be either the NVMe character
+device (ex: /dev/nvme0) or block device (ex: /dev/nvme0n1).
+
+This will only work on WDC devices supporting this feature.
+Results for any other device are undefined.
+
+On success it returns 0, error code otherwise.
+
+OPTIONS
+-------
+-o ::
+--output-format=::
+ Set the reporting format to 'normal', or
+ 'json'. Only one output format can be used at a time.
+ Default is normal.
+
+-n ::
+--namespace-id=::
+ Sets the command's nsid value to the given nsid. Defaults to
+ 0xffffffff if not given. This option may not affect anything
+ depending on the log page, which may or may not be specific to
+ a namespace.
+
+EXAMPLES
+--------
+* Has the program issue WDC vs-hw-rev-log plugin Command :
++
+------------
+# nvme wdc vs-hw-rev-log /dev/nvme0
+------------
+
+NVME
+----
+Part of the nvme-user suite.
diff --git a/Documentation/nvme-wdc-vs-internal-log.1 b/Documentation/nvme-wdc-vs-internal-log.1
index 1a557e3..a44671c 100644
--- a/Documentation/nvme-wdc-vs-internal-log.1
+++ b/Documentation/nvme-wdc-vs-internal-log.1
@@ -2,12 +2,12 @@
.\" Title: nvme-wdc-vs-internal-log
.\" Author: [FIXME: author] [see http://www.docbook.org/tdg5/en/html/author]
.\" Generator: DocBook XSL Stylesheets vsnapshot
-.\" Date: 04/08/2022
+.\" Date: 07/14/2022
.\" Manual: NVMe Manual
.\" Source: NVMe
.\" Language: English
.\"
-.TH "NVME\-WDC\-VS\-INTER" "1" "04/08/2022" "NVMe" "NVMe Manual"
+.TH "NVME\-WDC\-VS\-INTER" "1" "07/14/2022" "NVMe" "NVMe Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/Documentation/nvme-wdc-vs-internal-log.html b/Documentation/nvme-wdc-vs-internal-log.html
index ef6e70e..0f0319a 100644
--- a/Documentation/nvme-wdc-vs-internal-log.html
+++ b/Documentation/nvme-wdc-vs-internal-log.html
@@ -4,7 +4,7 @@
-
+
nvme-wdc-vs-internal-log(1)