Updating packaging for upstreams migration to meson, temporarily skipping udeb-build (needs further work).
Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
parent
e4376063b0
commit
f37818d6f4
6 changed files with 48 additions and 30 deletions
5
debian/TODO
vendored
Normal file
5
debian/TODO
vendored
Normal file
|
@ -0,0 +1,5 @@
|
|||
TODO
|
||||
|
||||
* readd udeb
|
||||
* update copyright
|
||||
* run test that don't require nvme devices
|
14
debian/control
vendored
14
debian/control
vendored
|
@ -3,10 +3,24 @@ Section: admin
|
|||
Priority: optional
|
||||
Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
|
||||
Build-Depends:
|
||||
asciidoc,
|
||||
cmake,
|
||||
debhelper-compat (= 13),
|
||||
flake8 <!nocheck>,
|
||||
isort <!nocheck>,
|
||||
libhugetlbfs-dev,
|
||||
libjson-c-dev,
|
||||
libnvme-dev,
|
||||
libssl-dev,
|
||||
meson,
|
||||
mypy <!nocheck>,
|
||||
pkg-config,
|
||||
python3-autopep8 <!nocheck>,
|
||||
python3-nose2 <!nocheck>,
|
||||
uuid-dev,
|
||||
uuid-runtime,
|
||||
xmlto,
|
||||
zlib1g-dev,
|
||||
Rules-Requires-Root: no
|
||||
Standards-Version: 4.6.1
|
||||
Homepage: https://github.com/linux-nvme/nvme-cli
|
||||
|
|
6
debian/patches/debian/0001-systemd.patch
vendored
6
debian/patches/debian/0001-systemd.patch
vendored
|
@ -1,9 +1,9 @@
|
|||
Author: Daniel Baumann <daniel.baumann@progress-linux.org>
|
||||
Description: Removing obsolete settings for newer systemd versions.
|
||||
|
||||
diff -Naurp nvme-cli.orig/nvmf-autoconnect/systemd/nvmf-connect@.service nvme-cli/nvmf-autoconnect/systemd/nvmf-connect@.service
|
||||
--- nvme-cli.orig/nvmf-autoconnect/systemd/nvmf-connect@.service
|
||||
+++ nvme-cli/nvmf-autoconnect/systemd/nvmf-connect@.service
|
||||
diff -Naurp nvme-cli.orig/nvmf-autoconnect/systemd/nvmf-connect@.service.in nvme-cli/nvmf-autoconnect/systemd/nvmf-connect@.service.in
|
||||
--- nvme-cli.orig/nvmf-autoconnect/systemd/nvmf-connect@.service.in
|
||||
+++ nvme-cli/nvmf-autoconnect/systemd/nvmf-connect@.service.in
|
||||
@@ -4,7 +4,6 @@
|
||||
|
||||
[Unit]
|
||||
|
|
15
debian/patches/debian/0002-meson-nose2.patch
vendored
Normal file
15
debian/patches/debian/0002-meson-nose2.patch
vendored
Normal file
|
@ -0,0 +1,15 @@
|
|||
Author: Daniel Baumann <daniel.baumann@progress-linux.org>
|
||||
Description: Updating meson to find /usr/bin/nose2-3 (python3).
|
||||
|
||||
diff -Naurp nvme-cli.orig/tests/meson.build nvme-cli/tests/meson.build
|
||||
--- nvme-cli.orig/tests/meson.build
|
||||
+++ nvme-cli/tests/meson.build
|
||||
@@ -24,7 +24,7 @@ tests = [
|
||||
'nvme_get_lba_status_test',
|
||||
]
|
||||
|
||||
-runtests = find_program('nose2', required : false)
|
||||
+runtests = find_program('nose2-3', required : false)
|
||||
|
||||
if runtests.found()
|
||||
foreach t : tests
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
|
@ -1 +1,2 @@
|
|||
debian/0001-systemd.patch
|
||||
debian/0002-meson-nose2.patch
|
||||
|
|
37
debian/rules
vendored
37
debian/rules
vendored
|
@ -1,38 +1,21 @@
|
|||
#!/usr/bin/make -f
|
||||
|
||||
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
|
||||
|
||||
%:
|
||||
dh ${@}
|
||||
dh ${@} --buildsystem=meson
|
||||
|
||||
execute_after_dh_auto_clean:
|
||||
rm -rf build-udeb
|
||||
|
||||
execute_after_dh_auto_configure:
|
||||
mkdir -p build-udeb
|
||||
find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -and -not -name ".pc*" -exec cp -a {} build-udeb \;
|
||||
dh_auto_configure --builddirectory build-udeb
|
||||
|
||||
execute_after_dh_auto_build:
|
||||
DEB_CFLAGS_MAINT_APPEND=-Os dh_auto_build \
|
||||
--reload-all-buildenv-variables \
|
||||
--builddirectory build-udeb \
|
||||
-- \
|
||||
nvme HAVE_SYSTEMD=no LIBHUGETLBFS=no
|
||||
override_dh_auto_configure:
|
||||
dh_auto_configure -- -Ddocs=man -Ddocs-build=true -Dsystemddir=/lib/systemd -Dudevrulesdir=/lib/udev
|
||||
|
||||
execute_after_dh_auto_install:
|
||||
$(MAKE) -C build-udeb install-bin DESTDIR=$(CURDIR)/debian/nvme-cli-udeb PREFIX=/usr
|
||||
# temporarily building without udeb
|
||||
rm -rf debian/nvme-cli
|
||||
mv debian/tmp debian/nvme-cli
|
||||
|
||||
override_dh_auto_install:
|
||||
dh_auto_install -- DESTDIR=$(CURDIR)/debian/nvme-cli PREFIX=/usr UDEVDIR=/lib/udev SYSTEMDDIR=/lib/systemd
|
||||
# removing unused files
|
||||
rm -rf debian/nvme-cli/usr/lib/dracut
|
||||
|
||||
# removing unique files
|
||||
rm -f debian/nvme-cli/etc/nvme/hostid
|
||||
rm -f debian/nvme-cli/etc/nvme/hostnqn
|
||||
rm -f debian/nvme-cli/usr/lib/dracut/dracut.conf.d/70-nvmf-autoconnect.conf
|
||||
|
||||
# removing useless files
|
||||
-rmdir -p debian/nvme-cli/usr/lib/dracut/dracut.conf.d
|
||||
# fix wrong-manual-section
|
||||
sed -i -e 's|\\" "1"|" "1"|' debian/nvme-cli/usr/share/man/*/*.1
|
||||
|
||||
override_dh_auto_test:
|
||||
# disabled, requires a NVMe device
|
||||
|
|
Loading…
Add table
Reference in a new issue