1
0
Fork 0
zutils/debian/patches/debian/0002-zupdate.patch
Daniel Baumann 42cdc6d40e
Refreshing zupdate.patch.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-24 06:00:57 +01:00

15 lines
555 B
Diff

Author: Daniel Baumann <daniel.baumann@progress-linux.org>
Description: Avoid linking zupdate statically.
diff -Naurp zutils.orig/Makefile.in zutils/Makefile.in
--- zutils.orig/Makefile.in
+++ zutils/Makefile.in
@@ -52,7 +52,7 @@ ztest : $(ztest_objs)
$(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(ztest_objs)
zupdate : $(zupdate_objs)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(zupdate_objs)
+ $(CXX) $(CXXFLAGS) -o $@ $(zupdate_objs)
rc.o : rc.cc
$(CXX) $(CPPFLAGS) $(CXXFLAGS) -DPROGVERSION=\"$(pkgversion)\" -DSYSCONFDIR=\"$(sysconfdir)\" -c -o $@ $<