1
0
Fork 0

Adding debian version 7.5.1+dfsg-1.

Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
Daniel Baumann 2025-02-07 01:19:39 +01:00
parent 916e3d5336
commit 0684f2243e
Signed by: daniel
GPG key ID: FBB4F0E80A80222F
10 changed files with 156 additions and 0 deletions

10
debian/changelog vendored Normal file
View file

@ -0,0 +1,10 @@
foxyproxy-firefox-extension (7.5.1+dfsg-1) sid; urgency=medium
* Initial upload to sid (Closes: #985147).
* Removed embedded fonts-font-awesome copy and replacing it with symlinks
to use the one from the system.
* Removed ~65MB archived xpi files of previous foxyproxy versions included
in the git repository.
* Adding patch to disable first run page.
-- Daniel Baumann <daniel.baumann@progress-linux.org> Sat, 13 Mar 2021 16:38:34 +0100

29
debian/control vendored Normal file
View file

@ -0,0 +1,29 @@
Source: foxyproxy-firefox-extension
Section: web
Priority: optional
Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
Build-Depends:
debhelper-compat (= 13),
Rules-Requires-Root: no
Standards-Version: 4.5.1
Homepage: https://github.com/foxyproxy/firefox-extension
Vcs-Browser: https://git.progress-linux.org/packages/fuchur-extras/foxyproxy-firefox-extension
Vcs-Git: https://git.progress-linux.org/packages/fuchur-extras/foxyproxy-firefox-extension
Package: webext-foxyproxy
Section: web
Architecture: all
Depends:
fonts-font-awesome,
${misc:Depends},
Recommends:
firefox (>= 57) | firefox-esr (>= 57),
Enhances:
firefox,
firefox-esr,
Description: Advanced proxy management for Firefox
FoxyProxy is an advanced proxy management tool that completely replaces
Firefox's limited proxying capabilities.
.
It features automatically switching the internet connection across one or more
proxy servers based on URL patterns.

49
debian/copyright vendored Normal file
View file

@ -0,0 +1,49 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: firefox-extension
Upstream-Contact: Eric Jung <eric.jung@getfoxyproxy.org>
Source: https://github.com/foxyproxy/firefox-extension/releases
Files-excluded: archive, src/styles/fontawesome-*.css, src/styles/fonts/*
Files: *
Copyright: 2019-2020 Eric Jung <eric.jung@getfoxyproxy.org>
License: GPL-2
Files: src/scripts/jscolor-*.js
Copyright: 2010-2015 Jan Odvarko <jan@odvarko.cz>
License: GPL-3
Files: debian/*
Copyright: 2021 Daniel Baumann <daniel.baumann@progress-linux.org>
License: GPL-2
License: GPL-2
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, version 2 of the License.
.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
.
You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
.
The complete text of the GNU General Public License
can be found in /usr/share/common-licenses/GPL-2 file.
License: GPL-3
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, version 3 of the License.
.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
.
You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
.
The complete text of the GNU General Public License
can be found in /usr/share/common-licenses/GPL-3 file.

View file

@ -0,0 +1,31 @@
Author: Daniel Baumann <daniel.baumann@progress-linux.org>
Description: Silencing first run/update page.
diff -Naurp foxyproxy-firefox-extension.orig/src/scripts/background.js foxyproxy-firefox-extension/src/scripts/background.js
--- foxyproxy-firefox-extension.orig/src/scripts/background.js 2020-07-29 20:43:31.000000000 +0200
+++ foxyproxy-firefox-extension/src/scripts/background.js 2021-03-13 17:58:11.959638800 +0100
@@ -49,17 +49,6 @@ chrome.webRequest.onAuthRequired.addList
chrome.webRequest.onCompleted.addListener(clearPending, {urls: ['*://*/*']});
chrome.webRequest.onErrorOccurred.addListener(clearPending, {urls: ['*://*/*']});
-chrome.runtime.onInstalled.addListener((details) => { // Installs Update Listener
- // reason: install | update | browser_update | shared_module_update
- switch (true) {
-
- case details.reason === 'install':
- case details.reason === 'update' && /^(3\.|4\.|5\.5|5\.6)/.test(details.previousVersion):
- chrome.tabs.create({url: '/about.html?welcome'});
- break;
- }
-});
-
// ----------------- User Preference -----------------------
chrome.storage.local.get(null, result => {
// browserVersion is not used & runtime.getBrowserInfo() is not supported on Chrome
@@ -272,4 +261,4 @@ function clearPending(request) {
}
delete authPending[request.requestId]; // no error
-}
\ No newline at end of file
+}

1
debian/patches/series vendored Normal file
View file

@ -0,0 +1 @@
debian/0001-disable-first-run-page.patch

28
debian/rules vendored Executable file
View file

@ -0,0 +1,28 @@
#!/usr/bin/make -f
FIREFOX_ID := {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
EXTENSION_ID := foxyproxy@eric.h.jung
SHELL := sh -e
%:
dh ${@}
override_dh_auto_install:
mkdir -p debian/webext-foxyproxy/usr/share/webext
cp -a src debian/webext-foxyproxy/usr/share/webext/foxyproxy
# fonts-font-awesome
sed -i -e 's|styles/fontawesome-.*.css|styles/font-awesome.min.css|g' debian/webext-foxyproxy/usr/share/webext/foxyproxy/*.html
execute_before_dh_link:
mkdir -p debian/webext-foxyproxy/usr/share/mozilla/extensions/${FIREFOX_ID}
ln -s /usr/share/webext/foxyproxy debian/webext-foxyproxy/usr/share/mozilla/extensions/${FIREFOX_ID}/${EXTENSION_ID}
execute_after_dh_missing:
# fonts-font-awesome
@if grep -qs -r 'styles/fontawesome-.*.css' debian/webext-foxyproxy/usr/share/webext/foxyproxy; \
then \
echo "E: found remaining references to embedded fonts-font-awesome, aborting."; \
exit 1; \
fi

1
debian/source/format vendored Normal file
View file

@ -0,0 +1 @@
3.0 (quilt)

4
debian/watch vendored Normal file
View file

@ -0,0 +1,4 @@
version=4
opts=filenamemangle=s/.+\/v?(\d\S+)\.tar\.gz/firefox-extension-$1\.tar\.gz/ \
dversionmangle=s/\+(debian|dfsg|ds|deb)\d*$// \
https://github.com/foxyproxy/firefox-extension/releases .*/v?(\d\S+)\.tar\.gz

1
debian/webext-foxyproxy.docs vendored Normal file
View file

@ -0,0 +1 @@
pattern-specifications.md

2
debian/webext-foxyproxy.links vendored Normal file
View file

@ -0,0 +1,2 @@
/usr/share/fonts-font-awesome/css/font-awesome.min.css /usr/share/webext/foxyproxy/styles/font-awesome.min.css
/usr/share/fonts-font-awesome/fonts /usr/share/webext/foxyproxy/styles/fonts