diff --git a/NEWS.md b/NEWS.md
index bdda8d3..5fa3fd4 100644
--- a/NEWS.md
+++ b/NEWS.md
@@ -1,5 +1,11 @@
 # STorage Appliance Services (STAS)
 
+## Changes with release 2.2.2
+
+Bug fixes:
+
+* Fix migration of old "last known config" to new format. Old TID objects did not contain a `_cfg` member. Therefore, one needs to check for its existence (through introspection) before blindly trying to access it.
+
 ## Changes with release 2.2.1
 
 Added a few more unit and coverage tests. Fixed the following bugs.
diff --git a/meson.build b/meson.build
index b84e3d1..bf2dda5 100644
--- a/meson.build
+++ b/meson.build
@@ -9,7 +9,7 @@
 project(
     'nvme-stas',
     meson_version: '>= 0.53.0',
-    version: '2.2.1',
+    version: '2.2.2',
     license: 'Apache-2.0',
     default_options: [
         'buildtype=release',
diff --git a/staslib/trid.py b/staslib/trid.py
index ea40b7d..d9a05ba 100644
--- a/staslib/trid.py
+++ b/staslib/trid.py
@@ -106,7 +106,12 @@ class TID:  # pylint: disable=too-many-instance-attributes
             'host-traddr': self.host_traddr,
             'host-iface': self.host_iface,
         }
-        data.update(self._cfg)
+
+        # When migrating an old last known config, the "_cfg" member may
+        # not exist. Therefor retrive it with getattr() to avoid a crash.
+        cfg = getattr(self, '_cfg', None)
+        if cfg:
+            data.update(cfg)
         return data
 
     def __str__(self):