28 lines
912 B
Diff
28 lines
912 B
Diff
From: Carl Suster <carl@contraflo.ws>
|
|
Date: Sat, 7 Jan 2017 14:39:14 +1100
|
|
Subject: enable Sphinx html_copy_source
|
|
|
|
We would like for the HTML source files to be installed, and they are
|
|
needed for the search page. In theory this could be done by passing an
|
|
argument `-Dhtml_copy_source=1` in debian/rules, however this causes
|
|
HAS_SOURCE to be equal to 1 instead of True so dh_sphinxdoc fails with a
|
|
"doesn't look like a Sphinc search page" error.
|
|
|
|
Forwarded: no
|
|
---
|
|
docs/conf.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/docs/conf.py b/docs/conf.py
|
|
index 7580d0c..12ab980 100644
|
|
--- a/docs/conf.py
|
|
+++ b/docs/conf.py
|
|
@@ -26,7 +26,7 @@ html_context = dict(
|
|
github_version=os.environ.get('TRAVIS_BRANCH', 'master'),
|
|
source_suffix='.rst',
|
|
)
|
|
-html_copy_source = False
|
|
+html_copy_source = True
|
|
html_favicon = 'favicon.ico'
|
|
html_theme = 'sphinx_rtd_theme'
|
|
html_title = project
|