1
0
Fork 0

Removing dont-use-setuptools-scm.patch, not needed anymore with new upstream version.

Signed-off-by: Daniel Baumann <daniel@debian.org>
This commit is contained in:
Daniel Baumann 2025-02-05 19:15:37 +01:00
parent 34301453f8
commit d3f6049cb3
Signed by: daniel
GPG key ID: FBB4F0E80A80222F
2 changed files with 0 additions and 33 deletions

View file

@ -1,32 +0,0 @@
--- a/setup.py
+++ b/setup.py
@@ -5,6 +5,12 @@ from os import path
from setuptools import setup
+
+# https://packaging.python.org/guides/single-sourcing-package-version/
+version = {}
+with open('tqdm/_dist_ver.py') as fp:
+ exec(fp.read(), version)
+
src_dir = path.abspath(path.dirname(__file__))
if sys.argv[1].lower().strip() == 'make': # exec Makefile commands
import pymake
@@ -13,4 +19,4 @@ if sys.argv[1].lower().strip() == 'make'
# Stop to avoid setup.py raising non-standard command error
sys.exit(0)
-setup(use_scm_version=True)
+setup(version=version['__version__'])
--- a/setup.cfg
+++ b/setup.cfg
@@ -74,7 +74,7 @@ classifiers =
Topic :: Utilities
[options]
-setup_requires = setuptools>=42; setuptools_scm[toml]>=3.4
+setup_requires = setuptools>=42
python_requires = >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*
install_requires =
colorama; platform_system == 'Windows'

View file

@ -1,3 +1,2 @@
dont-use-setuptools-scm.patch
pandas2p1_ignore_warnings.patch pandas2p1_ignore_warnings.patch
python3p12_compat.patch python3p12_compat.patch