From 9df2e9552714f1a5b7c43ebb2d131e486f20161f Mon Sep 17 00:00:00 2001
From: Daniel Baumann <daniel@debian.org>
Date: Mon, 24 Mar 2025 19:40:02 +0100
Subject: [PATCH] Adding extension makefiles.

Signed-off-by: Daniel Baumann <daniel@debian.org>
---
 extensions/disable-workspace-switcher.mk | 51 +++++++++++++++++++++
 extensions/hibernate-status.mk           | 55 +++++++++++++++++++++++
 extensions/multi-monitors-add-on.mk      | 57 ++++++++++++++++++++++++
 3 files changed, 163 insertions(+)
 create mode 100644 extensions/disable-workspace-switcher.mk
 create mode 100644 extensions/hibernate-status.mk
 create mode 100644 extensions/multi-monitors-add-on.mk

diff --git a/extensions/disable-workspace-switcher.mk b/extensions/disable-workspace-switcher.mk
new file mode 100644
index 0000000..f522857
--- /dev/null
+++ b/extensions/disable-workspace-switcher.mk
@@ -0,0 +1,51 @@
+# Progress Linux: gnome-shell-extensions-extra
+
+# Copyright (C) 2010-2023 Daniel Baumann <daniel.baumann@progress-linux.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <https://www.gnu.org/licenses/>.
+
+# Build-Depends:
+# none
+
+SHELL := sh -e
+
+EXTENSION := disable-workspace-switcher
+UUID := $(shell awk -F\" '/"uuid": / { print $$4 }' $(EXTENSION)/*@*/metadata.json)
+
+all:
+
+test:
+
+build:
+
+install:
+	mkdir -p $(DESTDIR)/usr/share/gnome-shell/extensions
+	cp -a $(EXTENSION)/$(UUID) $(DESTDIR)/usr/share/gnome-shell/extensions
+
+uninstall:
+	rm -rf $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)
+	rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
+
+clean:
+
+distclean:
+
+reinstall: uninstall install
+
+upstream:
+	rm -rf $(EXTENSION)
+	git clone https://github.com/jbradaric/$(EXTENSION)
+	rm -rf $(EXTENSION)/.git
diff --git a/extensions/hibernate-status.mk b/extensions/hibernate-status.mk
new file mode 100644
index 0000000..05651b5
--- /dev/null
+++ b/extensions/hibernate-status.mk
@@ -0,0 +1,55 @@
+# Progress Linux: gnome-shell-extensions-extra
+
+# Copyright (C) 2010-2023 Daniel Baumann <daniel.baumann@progress-linux.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <https://www.gnu.org/licenses/>.
+
+# Build-Depends:
+# libglib2.0-bin
+
+SHELL := sh -e
+
+EXTENSION := hibernate-status
+UUID := $(shell awk -F\" '/"uuid": / { print $$4 }' $(EXTENSION)/metadata.json)
+
+all:
+
+test:
+
+build:
+
+install:
+	$(MAKE) -C $(EXTENSION) DESTDIR=$(DESTDIR) install
+
+	# removing unused files
+	rm -f $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)/LICENSE
+	rm -f $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)/README.md
+
+uninstall:
+	rm -rf $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)
+	rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
+
+clean:
+	$(MAKE) -C $(EXTENSION) clean
+
+distclean:
+
+reinstall: uninstall install
+
+upstream:
+	rm -rf $(EXTENSION)
+	git clone https://github.com/arelange/gnome-shell-extension-$(EXTENSION) $(EXTENSION)
+	rm -rf $(EXTENSION)/.git
diff --git a/extensions/multi-monitors-add-on.mk b/extensions/multi-monitors-add-on.mk
new file mode 100644
index 0000000..0354876
--- /dev/null
+++ b/extensions/multi-monitors-add-on.mk
@@ -0,0 +1,57 @@
+# Progress Linux: gnome-shell-extensions-extra
+
+# Copyright (C) 2010-2023 Daniel Baumann <daniel.baumann@progress-linux.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <https://www.gnu.org/licenses/>.
+
+# Build-Depends:
+# gettext libglib2.0-bin
+
+SHELL := sh -e
+
+EXTENSION := multi-monitors-add-on
+UUID := $(shell awk -F\" '/"uuid": / { print $$4 }' $(EXTENSION)/*@*/metadata.json)
+
+all:
+
+test:
+
+build:
+	for TRANSLATION in $(EXTENSION)/$(UUID)/locale/*; \
+	do \
+		msgfmt -cv -o $${TRANSLATION}/LC_MESSAGES/$(EXTENSION).mo $${TRANSLATION}/LC_MESSAGES/$(EXTENSION).po; \
+	done
+
+	glib-compile-schemas --strict --targetdir=$(EXTENSION)/$(UUID)/schemas/ $(EXTENSION)/$(UUID)/schemas
+
+install:
+	mkdir -p $(DESTDIR)/usr/share/gnome-shell/extensions
+	cp -a $(EXTENSION)/$(UUID) $(DESTDIR)/usr/share/gnome-shell/extensions
+
+uninstall:
+	rm -rf $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)
+	rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
+
+clean:
+
+distclean:
+
+reinstall: uninstall install
+
+upstream:
+	rm -rf $(EXTENSION)
+	git clone https://github.com/realh/$(EXTENSION)
+	rm -rf $(EXTENSION)/.git