1
0
Fork 0
mdadm/debian/patches/debian/0007-no-Werror.patch
Daniel Baumann 5b11395853
Refreshing no-Werror.patch.
Signed-off-by: Daniel Baumann <daniel@debian.org>
2025-02-14 06:02:02 +01:00

18 lines
706 B
Diff

Author: Martin F. Krafft <madduck@debian.org>
Description: Remove -Werror from compiler flags.
-Werror seems like a bad idea on released/packaged code because a toolchain
update (introducing new warnings) could break the build. We'll let upstream
use it to beautify the code, but remove it for out builds.
diff -Naurp mdadm.orig/Makefile mdadm/Makefile
--- mdadm.orig/Makefile
+++ mdadm/Makefile
@@ -50,7 +50,7 @@ ifeq ($(origin CC),default)
CC := $(CROSS_COMPILE)gcc
endif
CXFLAGS ?= -ggdb
-CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
+CWFLAGS = -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
ifdef WARN_UNUSED
CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O3
endif